Kamis, 25 Agustus 2016

Tugas Rancang Bangun Jaringan 4


TUGAS RANCANG BANGUN JARINGAN 4
Topik  : Pengaturan Jaringan Dalam Suatu Perusahaan
Jadwal  :
Hari    : Jumat, 26 Agustus 2016. Pukul 07.00 - 11.45.
Soal :
1.  Jelaskan apa yang kamu ketahui tentang Routing Dinamis ?
2. Ada barapa jenis roouting Dinamis ? Sebutkan dan jelaskan ?
3. Jelaskan apa yang kamu ketahui tentang Routing Dinamis RIP ?
4. Bagaimana alur router mempelajari jalur tujuannya dengan metode RIP ?
5. Tuliskan kelebihan menggunakan metode Routing RIP ?
6. Tuliskan kekurangan menggunakan metode Routing RIP ?
7. Sebutkan dan jelaskan metode-metode untuk mengatasi Routing Loop ?
Jawab :  
 
 1. Dynamic Routing (Router Dinamis) adalah sebuah router yang memiliki dan membuat tabel routing secara otomatis, dengan mendengarkan lalu lintas jaringan dan juga dengan saling berhubungan antara router lainnya. Protokol routing mengatur router-router sehingga dapat berkomunikasi satu dengan yang lain dan saling memberikan informasi satu dengan yang lain dan saling memberikan informasi routing yang dapat mengubah isi forwarding table, tergantung keadaan jaringannya. Dengan cara ini, router-router mengetahui keadaan jaringan yang terakhir dan mampu meneruskan data ke arah yang benar. Dengan kata lain, routing dinamik adalah proses pengisian data routing di table routing secara otoma 
  
2.  Mcam-Macam dari Routing Dinamis (Dynamic Router) :
  • RIP (Routing Information Protocol)
Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Oleh karena itu protokol ini diklasifikasikan sebagai Interior GatewayProtocol (IGP). Protokol ini menggunakan algoritma Distance-Vector Routing
  • IGRP (Internal Gateway Routing Protokol)
merupakan suatu penjaluran jarak antara vektor protokol, bahwa masing-masing penjaluran bertugas untuk mengirimkan semua atau sebagian dari isi table penjaluran dalam penjaluran pesan untuk memperbaharui pada waktu tertentu untuk masing-masing penjaluran.
Penjaluran memilih alur yang terbaik antara sumber dan tujuan. Untuk menyediakan fleksibilitas tambahan, IGRP mengijinkan untuk melakukan penjaluran multipath. Bentuk garis equal bandwidth dapat menjalankan arus lalu lintas dalam round robin, dengan melakukan peralihan secara otomatis kepada garis kedua jika sampai garis kesatu turun.
  • OSPF (Open Shortest Path First) Merupakan protokol routing link state dan digunakan untuk menghubungkan router-router yang berada dalam satu Autonomous System (AS) sehingga protokol routing ini termasuk juga kategori Interior Gateway Protocol (IGP)

  • EIGRP (Enhanced Internal Gateway Routing Protokol) EIGRP (Enhanced Interior Gateway Routing Protocol) adalah routing protocol yang hanya di adopsi oleh router cisco atau sering disebut sebagai proprietary protocol pada CISCO. Dimana EIGRP ini hanya bisa digunakan sesama router CISCO saja dan routing ini tidak didukung dalam jenis router yang  lain.

  • BGP (Border Gateway Protokol) Border Gateway Protocol (BGP) adalah salah satu jenis routing protocol yang berfungsi untuk mempertukarkan informasi antar Autonomous System (AS). Autonomous System (AS) adalah kumpulan dari jaringan-jaringan dalam satu administrasi yang mempunyai strategi routing bersama. BGP merupakan protocol routing yang memanfaatkan protokol TCP untuk pertukaran informasi antar router. Dengan protocol TCP ini BGP tidak perlu lagi menggunakan protocol lain untuk menangani fragmentasi, retransmisi, acknowledgement dan sequencing. Routing protocol BGP berdasarkan fungsi, lokasi dan kebutuhannya dibedakan menjadi dua bagian yaitu iBGP dan eBGP.
    3.  RIP (Routing Information Protocol)
Routing Information Protocol (RIP) adalah sebuah protokol routing dinamis yang digunakan dalam jaringan LAN (Local Area Network) dan WAN (Wide Area Network). Oleh karena itu protokol ini diklasifikasikan sebagai Interior Gateway Protocol (IGP). Protokol ini menggunakan algoritma Distance-Vector Routing. Pertama kali didefinisikan dalam RFC 1058 (1988). Protokol ini telah dikembangkan beberapa kali, sehingga terciptalah RIP Versi 2 (RFC 2453). Kedua versi ini masih digunakan sampai sekarang, meskipun begitu secara teknis mereka telah dianggap usang oleh teknik-teknik yang lebih maju, seperti Open Shortest Path First (OSPF) dan protokol OSI IS-IS. RIP juga telah diadaptasi untuk digunakan dalam jaringan IPv6, yang dikenal sebagai standar RIPng (RIP Next Generation / RIP generasi berikutnya), yang diterbitkan dalam RFC 2080 (1997).

                 5.   Kelebihan
·         RIP menggunakan metode Triggered Update
·   RIP memiliki timer untuk mengetahui kapan router harus kembali memberikan informasi routing. Jika terjadi perubahan pada jaringan, sementara timer belum habis, router tetap harus mengirimkan informasi routing karena dipicu oleh perubahan tersebut (triggered update)
·    Mengatur routing menggunakan RIP tidak rumit dan memberikan hasil yang cukup dapat diterima, terlebih jika jarang terjadi kegagalan link jaringan.

         6.    Kekurangan
·         Jumlah host Terbatas
·         RIP tidak memiliki informasi tentang subnet setiap route.
·         RIP tidak mendukung Variable Length Subnet Masking (VLSM).
·     Ketika pertama kali dijalankan hanya mengetahui cara routing ke dirinya sendiri (informasi lokal) dan tidak mengetahui topologi jaringan tempatnya berada
·         untuk jaringan yang besar dan kompleks, RIP mungkin tidak cukup. Dalam kondisi demikian, penghitungan routing dalam RIP sering membutuhkan waktu yang lama, dan menyebabkan terjadinya routing loop.

  7.     Cara Mengatasi Rooting Loops

                 Untuk Mengatasi Routing Loop Digunakan beberapa metode antara lain :
·         Split horizon digunakan RIP untuk meminimalkan efek bouncing. Prinsip yang digunakan split horizon sederhana: jika node A menyampaikan datagram ke tujuan X melalui node B, maka bagi B tidak masuk akal untuk mencapai tujuan X melalui A. Jadi, A tidak perlu memberitahu B bahwa X dapat dicapai B melalui A.
·         Untuk mencegah kasus menghitung-sampai-tak-hingga, RIP menggunakan metode Triggered Update. RIP memiliki timer untuk mengetahui kapan router harus kembali memberikan informasi routing. Jika terjadi perubahan pada jaringan, sementara timer belum habis, router tetap harus mengirimkan informasi routing karena dipicu oleh perubahan tersebut (triggered update). Dengan demikian, router-router di jaringan dapat dengan cepat mengetahui perubahan yang terjadi dan meminimalkan kemungkinan routing loop terjadi.
·      Holddown timer adalah interval tertentu dalam detik yang berlaku untuk semua interface router yang menyatakan bahwa suatu route tidak dapat dicapai.
·    poisonnus reverse, yaitu router tetap mmberikan informasi mengenai suatu router kepada sumber, tetapi memberikan nilai tidak terhingga. Dengan poisonous reverse, router-router tetap dapat mengetahui bahwa suatu jaringan ada. 

Gambar Praktek di Packet Tracer

Tidak ada komentar:

Posting Komentar